test4


※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

OSPFのデフォルトルート配布


Router1(config)#ip route 0.0.0.0 0.0.0.0 interface Fa 0/0
Router1(config)#router ospf 1
Router1(config-router)#default-information originate

Router1のルーティングテーブルにスタティックルートが載って
他のルータのルーティングテーブルにはデフォルトルート(O*Ex~)が載る

Router1(config)#router ospf 1
Router1(config-router)#default-information originate always

Router1のルーティングテーブルにはスタティックルートは載らず
他のルータのルーティングテーブルにはデフォルトルート(O*Ex~)が載る

EIGRPの場合


Router2(config)#ip route 0.0.0.0 0.0.0.0 interface fa 1/0
Router2(config)#router eigrp 200
Router2(config-router)#network 0.0.0.0

Router2のルーティングテーブルにはスタティックルートが載って
他のルータのルーティングテーブルにはデフォルトルート(D*~)が載る

Router2(config)#ip route 0.0.0.0 0.0.0.0 interface fa 1/0
Router2(config)#router eigrp 200
Router2(config-router)#redistribute static

Router2のルーティングテーブルにはスタティックルートが載って
他のルータのルーティングテーブルにはデフォルトルートが外部ルートとして(D*EX~)が載る

Router2(config)#router eigrp 200
Router2(config-router)#ip default-network 192.168.30.0 <--Router2に既知のクラスフルn/wアドレス

Router2のルーティングテーブルにはデフォルトルート(C*~)が載って
他のルータのルーティングテーブルにはデフォルトルート(D*~)が載る